Conduit

Arbitrum Sepolia is experiencing stalled finalized and safe heads
Resolved·Degraded performance

Fully resolved

Tue, Oct 14, 2025, 10:20 PM
(2 months ago)
·
Affected components
Updates

Resolved

Fully resolved

Tue, Oct 14, 2025, 10:20 PM

Monitoring

We applied a mitigation in place and all the testnets have seen recovery. We keep the situation monitored this full fix upstream from Arbitrum.

Tue, Oct 14, 2025, 06:36 PM(3 hours earlier)

Identified

The Arbitrum Sepolia RPCs are experiencing stalled finalized and safe heads. We are investigating but should be related to the Fusaka upgrade. We are testing a mitigation to restore operations. This impacts rollups settling on Arbitrum Sepolia.

Tue, Oct 14, 2025, 05:20 PM(1 hour earlier)
Powered by