Resolved
We've seen recovery on Ethereum and all systems are operating normally.
Monitoring
Ethereum mainnet is experiencing delayed transaction inclusion given high gas fees and congestion. Conduit Rollups may notice increased latency, lagging safe head and delay in processing withdrawals. Block production (unsafe head) is not impacted and functioning normally.